Newbie post 2, Question? - Honda Shadow Forums : Shadow Motorcycle Forum

Reply
 
LinkBack Thread Tools
Old 12-11-2012, 10:04 PM   #1 (permalink)
Junior Member
 
Sabre Smitty's Avatar
 
Join Date: Dec 2012
Location: Port Charlotte, Fl
Posts: 23
Question Newbie post 2, Question?

My Sabre has a turn signal issue.... They work sometimes.. I have cleaned the switch, i need to check the relay...
Is there anything else I might need to check??

Thanks for any help....
Sabre Smitty is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-12-2012, 08:49 AM   #2 (permalink)
Senior Member
 
Join Date: Nov 2010
Location: Columbus, GA
Posts: 2,226
Garage
Default

I would press the switch and listen to the relay. If you don't hear the steady metronome of "click...click....click" then you probably need a new relay. If your switch is clean especially. Other than that? The bulb itself maybe...
__________________
1985 Honda Rebel 250(Destroyed by being a newb)
Black
1996 Honda Shadow VLX 600(Sold)
Red/Black
2001 Honda Shadow Sabre 1100
Blue/Blue

kacealraid is online now   Reply With Quote
Old 12-12-2012, 09:02 PM   #3 (permalink)
Senior Member
 
Join Date: Feb 2012
Location: Vancouver BC
Posts: 1,687
Garage
Default

You say sometimes it works. Is that both sides? If both sides its not a bulb. I would reclean the switch since that is 90% the issue.

G.
gdb069 is offline   Reply With Quote
Old 12-12-2012, 11:59 PM   #4 (permalink)
Junior Member
 
Sabre Smitty's Avatar
 
Join Date: Dec 2012
Location: Port Charlotte, Fl
Posts: 23
Default

Well, the bike sat outside for a couple months.... I recleaned the switch, but no turn signals.. Yes it is both sides...
Can anyone tell, me where the relayt is located?? and No I do not hear the tick tick tick..

Thanks for the responses..
Sabre Smitty is offline   Reply With Quote
Old 12-13-2012, 07:10 AM   #5 (permalink)
Junior Member
 
Sabre Smitty's Avatar
 
Join Date: Dec 2012
Location: Port Charlotte, Fl
Posts: 23
Default

oops double post..

Last edited by Sabre Smitty; 12-14-2012 at 12:32 AM. Reason: double post.. delete
Sabre Smitty is offline   Reply With Quote
Old 12-14-2012, 12:30 AM   #6 (permalink)
Junior Member
 
Sabre Smitty's Avatar
 
Join Date: Dec 2012
Location: Port Charlotte, Fl
Posts: 23
Default

ok, so I went as far as taking the switch apart and cleaning it, it is getting current when turned on... the relay is not clicking, front light goes out, no rear light.. Power at relay.. checked all grounds.. last resort are the bulbs?? Unless someone can help me out here... Am I missing anything??
Sabre Smitty is offline   Reply With Quote
Old 12-14-2012, 07:50 AM   #7 (permalink)
Member
 
Dom.Five's Avatar
 
Join Date: Jun 2012
Location: Holbrook, Mass.
Posts: 196
Default

You did not tell us what year it is, New or used ? I have seen bikes that people have installed LED bulbs in them, do the same thing you are describing. Have you looked at / tested the bulbs ?
__________________
VT-1100C2

Vance & Hines Long Exhaust .
K&N air filter
Dom.Five is offline   Reply With Quote
Old 12-14-2012, 08:51 AM   #8 (permalink)
Senior Member
 
Join Date: Apr 2008
Location: Palatine, IL
Posts: 6,856
Default

Make sure all the bulbs and sockets are corrosion free. Check bulbs for good filiments.
jpr1968 is offline   Reply With Quote
Old 12-14-2012, 09:05 AM   #9 (permalink)
Junior Member
 
Sabre Smitty's Avatar
 
Join Date: Dec 2012
Location: Port Charlotte, Fl
Posts: 23
Default

Its a 2006 sabre, new to me... no led bulbs... I have not check the bulbs yet. I will be checking them on my break today..
__________________
2006 Shadow Sabre 1100, 5" risers, stebel air horn, led bulbs in turns and fog lights... more upgrades to come.
03 Odyssey
98 CRV
The Honda Family... Watch out for cars... they're everywhere...
Sabre Smitty is offline   Reply With Quote
Old 12-14-2012, 05:21 PM   #10 (permalink)
Junior Member
 
Sabre Smitty's Avatar
 
Join Date: Dec 2012
Location: Port Charlotte, Fl
Posts: 23
Default

bulbs checked out ok.... still no turn signals... The front running lights come on, and when you hit the switch, it goes out..?
all corrosion free..
__________________
2006 Shadow Sabre 1100, 5" risers, stebel air horn, led bulbs in turns and fog lights... more upgrades to come.
03 Odyssey
98 CRV
The Honda Family... Watch out for cars... they're everywhere...
Sabre Smitty is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 05:14 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum