Honda Shadow Forums : Shadow Motorcycle Forum - View Profile: squidchief

squidchief squidchief is offline

Senior Member

  Visitor Messages

Showing Visitor Messages 1 to 9 of 9
  1. sopo
    10-09-2013 05:46 PM - permalink
    Thank you. Had the best time ever and hope to get to hit the road again soon. Hope you're getting some good riding time in as well. Stay safe.
  2. HondaNut
    06-13-2013 10:56 PM - permalink
    Looks like it was just the slave cylinder. I took the cover off and it was pretty crusty under there. I swapped out the the seals with a KL kit and it seems to be holding steady thus far! This site was extremely helpful for the top banjo knowledge. My only gripe was that the the kit said it included an oil push rod seal, but it turned out it was a small rubber bushing for the end of the slave cylinder... I almost picked out my engine oil push rod seal thinking I'd be replacing.
  3. squidchief
    06-05-2013 12:18 PM - permalink
    get that brake fluid cleaned up with the quickness!!!!! it'll eat up anything it sits on.
  4. squidchief
    06-05-2013 12:17 PM - permalink
    there's only a couple of places it can leak from. Be carefull and check the sight glass real good. They have a tendancy to wear through and leak. I had to get some aircraft epoxy sealant and glue a filipino centavo against it. You can also use a dime, same size.... or order a rebuild kit. Do a search on here for tips on bleeding that clutch system. If you don't do it right it becomes an all day PIA.
  5. HondaNut
    06-05-2013 11:56 AM - permalink
    Thanks for the advice about the radiator hose. I'm thinking my clutch slave cylinder actually needs to be rebuilt. I went to jump on this morning and had no clutch pressure! Looks like the leak was traveling down the stator wires and dripping right on the connection for the radiator hose at the water pump! Tricky little thing! I'm going to pull the cover off tonight and see exactly what I'm dealing with.
  6. HondaNut
    05-31-2013 12:32 AM - permalink

    Did you ever figure out what to do about your lower radiator hose leak on the vt700? I seem to have just encountered the same problem, right at the water pump connection. Did you use some universal coolant hose? If so, do you remember the diameter?

  7. sopo
    03-14-2013 08:01 PM - permalink
    Thank you for your kind words.
  8. MarineCorpsFlorist
    06-15-2012 05:14 PM - permalink
    ah... all talk you know the type... screw em....he cries to his mommy
  9. MarineCorpsFlorist
    06-14-2012 09:23 PM - permalink
    Who and why? Maybe I can help. LOL

  About Me

  • About squidchief
    out West
    as long as it's outdoors....
  • Signature
    "For those of US who fought for it....FREEDOM..... has a flavor the protected will never know"


Total Posts
Visitor Messages
General Information
  • Last Activity: 06-09-2015 04:58 PM
  • Join Date: 06-23-2006
  • Referrals: 0


Showing Friends 1 to 4 of 4


12:07 PM - Mark-B mentioned squidchief in post


No results to display...
For the best viewing experience please update your browser to Google Chrome