Honda Shadow Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
2008 Honda Shadow 750, turn signal not working, installed new LED turn signal on the rear. did install the resistor to stop the fast blinker. I did check throughout the install to make sure everything worked. when it was all installed no issues with front or rear blinkers and brake light. Not sure when it happened but now my turn signal and brake lights do not come on. I can see the front turn signal try to go to the turn signal light but wont come on. I did install this a few weeks ago and everything worked fine but I am thinking it is the relay may have blown, I did buy a new one that can handle LED lights.
Also not sure if this is messing up my brake lights as well which worked a few days ago, do have the ST2 Brake module installed as well but not sure if I have the wires connected correctly.
 

·
Registered
1983 Honda vt750 Shadow
Joined
·
19,357 Posts
If it was working and now it is not check the fuses first.
Then look for any wiring problems where you made any changes.
 

·
Registered
2001 Valkyrie I/S
Joined
·
7,022 Posts
I'm not sure what you mean when you say "can see the front turn signal try to go to the turn signal light but wont come on." do you mean they flash dimly or quickly then stop?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Ramie, speaking of the front turn signal which are still factory. The two filament which one is always one by default but when u turn on a blinker the power is diverted to the secondary filament that blinks but there is no blinking as the fuse was blown. I will see tomorrow when I get the replacement.
 
1 - 5 of 5 Posts
Top