Honda Shadow Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
So I have been putting off this issue for a while. We are almost roadworthy except for the dang blinkers. I had led in the front and regular bulbs in the back, the right rear bulb was blown, so when I turned on right blinker only right front would work. By turning on left blinker ( led in front, bulb in rear) all working blinkers, except blown rear right bulb, would flash a normal flash, not fast, normal speed. I have swapped the flasher relay for a custom LED elfr-1 led flasher relay. I have also tried putting inline led load equalizers to no avail. At this point I might just mount painted flashlights on to use as blinkers. If anyone has any advice or can point me in the right direction it would be very appreciated.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
If you have a single indicator bulb on the dash for the turn signals, it back feeds the other side when you have one side on. Many guys have a trick with 2 diodes that fixes it.

So one diode kit would cure the whole bike? Or would I need more? Thankyou for your time!
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #9 ·
So I wired the diode kit in using the picture D’s spirit shared on this thread, and the left blinker worked fine. The headlight and tail light blinked instead of the right blinker... after removing diode kit and connecting wires back with their mates all blinkers worked as they should. Weird. Thought I was out of the woods but that wasn’t the case, we are back to all four blinkers blinking at the same time. My new question is if I disconnect the single indicator light would this problem continue? Or would that make the blinkers not work at all? Taping painted flashlights on the bike to use as blinkers is starting to not seem like such a bad idea.
 
1 - 4 of 4 Posts
Top