Honda Shadow Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I need some help! We own a 2009 Aero 750. The brake lights have the 3 flash warning when you apply the brakes. I put the Radiantz LED brake light and the Led Rear turn signal lights on the rear. They work great! The turn signal and brake light really light up when you apply the brakes and also the rear turn signals with the LEDs work perfectly. I decided to add amber LEDs to the front turn signals to have LEDS all the way around. When I added the front LEDS (also Radiantz) they flash very fast which in turn causes the rear turn signals to also flash very fast. When I put the stock bulbs back in everything works fine. I have read most of the threads pertaining to LEDs and I am somewhat confused!! Some say add digital flashers and some say add new flasher relay and others say add a load equalizer. My second question is, where is this located on the bike? Is it in the Side Cover or Headlight housing, this is where the noise is coming from when it flashes. When the turn signals are on, a green light will light up on the triple tree indicating that the signal is on. Any help would certainly be appreciated.
 

·
Registered
Joined
·
6,045 Posts
In my wife's o5, it's in the headlight bucket. Not sure if it's still in there on yours. You don't have a service manual, if not, invest in one. Get an electronic t/s flasher and it will solve your problem. There's not enough load on the LED bulbs hence the fast flash rate.
 

·
Premium Member
Joined
·
1,333 Posts
In my wife's o5, it's in the headlight bucket. Not sure if it's still in there on yours. You don't have a service manual, if not, invest in one. Get an electronic t/s flasher and it will solve your problem. There's not enough load on the LED bulbs hence the fast flash rate.

What is an "electric t/s flasher"? and what does it do?
 

·
Registered
Joined
·
576 Posts
Listen for the clicking when the signal is on if you need to locate it. Once you find the right area, you should be able to feel the click to be sure you change the correct unit.

Sent from my Samsung Epic 4G Touch using Motorcycle.com App
 

·
Registered
Joined
·
5 Posts
2011 mine was in the headlight cone. Replaced all bulbs with LEDs, then replaced the relay with a digital relay because i was having some flashing issue. Fixed all the lights but now, the little green indicator light on the fork doesnt work, also no more clicky lol
 
1 - 6 of 6 Posts
Top