Honda Shadow Forums banner

1 - 19 of 19 Posts

·
Registered
2002 shadow 750 black widow
Joined
·
7 Posts
Discussion Starter #1
Hey everyone. I own a Honda shadow vt 750 (the love of my life). One month ago the turning signals started to work "slowly", like 5 seconds after pushing the button. Now it doesn't work at all. I thought it could be the fuse but none is damaged. The lights themselves looks good. Unfortunately, i don't understand much about electric
 

·
Registered
1983 Honda vt750 Shadow
Joined
·
15,590 Posts
The year matters if you need wiring diagrams.
But in general some of the guys have had that from cold weather and the contacts in the switch gets poor.

Cleaning the switch will fix it.

Or the flasher relay is getting tired. Than can do it too
 

·
Registered
2002 shadow 750 black widow
Joined
·
7 Posts
Discussion Starter #5
The year matters if you need wiring diagrams.
But in general some of the guys have had that from cold weather and the contacts in the switch gets poor.

Cleaning the switch will fix it.

Or the flasher relay is getting tired. Than can do it too
Thanks I'll try it tomorrow
 

·
Registered
1983 Honda vt750 Shadow
Joined
·
15,590 Posts
The flasher relay only controls the turn flashing.
The headlight is a different circuit.
If you can wiggle the switch and it lights but doesn't flash, tap on the relay and it may blink a bit and you know it is going bad.
But clean the switch too . Usually that does it.
 

·
Registered
2001 Shadow Spirit 750
Joined
·
299 Posts
Post a couple pics if you have any. We love pics.
 

·
Registered
2001 Shadow Spirit 750
Joined
·
299 Posts
Nice. What pipes are those? I like 'em.
 

·
Registered
2002 shadow 750 black widow
Joined
·
7 Posts
Discussion Starter #12
Nice. What pipes are those? I like 'em.
2002 black widow edition original stock pipes ✌🏻 i wanted to change them, but i like the line and the sound it's pretty good (and honestly, here in Switzerland if you want to buy certified pipes you have to spend a lot 😅)
 

·
Registered
2001 Shadow Spirit 750
Joined
·
299 Posts
2002 black widow edition original stock pipes ✌🏻 i wanted to change them, but i like the line and the sound it's pretty good (and honestly, here in Switzerland if you want to buy certified pipes you have to spend a lot 😅)
WOW, I like the megaphone shape. Is that a stock ornament on the front fender also ?
 

·
Registered
Joined
·
11 Posts
So i cleaned up the switch and the signals are working perfectly now. Thank you a lot guys ✌🏻
I knew swifty2014 was 100% right after I got to work & thought about this yesterday. I answered as I was walking out the door not giving it much thought.
Now I have a question...

Should dielectric grease be put on the switch?
 

·
Registered
1983 Honda vt750 Shadow
Joined
·
15,590 Posts
Most guys have added clean dielectric to prevent corrosion, as well a grease
 

·
Registered
Joined
·
209 Posts
I have an 02 Shadow spirit VT750. Check the switch itself. The contacts get worn and corrosion buildup causeing a delay. Mine did this and mostly in cold weather. Once the bike warmed up it was fine. I ended up taking it apart and putting terminal grease used for the battery on it. The copper plating wears out. Eventually you will want to replace the switch housing all together. The symptoms are that all the signals are affected not just one light.
 

·
Registered
Joined
·
4 Posts
I had same problem recently on 2003 Shadow Spirit 750. Sprayed WD40 in switch, let it soak in for a night, problem solved. The switch works so well that it now determines by itself what to do. I just tell it which way I'm turning.:)
I have used WD40 for years on things like this, including spark plug boots, for years on car headlight switches, switches that slide across contacts, etc. and works great.I read about this technique years ago somewhere like in Popular Mechanics, and it never fails. My 2 cents.
 
1 - 19 of 19 Posts
Top